AWS Service Degradation Impacting Firstoken Operations – N. Virginia (us-east-1)
Resolved
Oct 20 at 02:41am HDT
At approximately 07:11 UTC, Firstoken began experiencing intermittent errors and increased latency in some services hosted in the AWS N. Virginia (us-east-1) region.
According to the AWS Service Health Dashboard, multiple AWS services —including EC2, Lambda, and DynamoDB— reported increased error rates and latencies due to an underlying DNS resolution issue.
This incident temporarily affected the availability of certain backend operations and caused delays in API responses for a subset of customers.
AWS engineers have applied mitigations, and recovery efforts are ongoing.
Firstoken’s core systems remain stable, and we continue to monitor the situation closely. Further updates will be provided as AWS releases new information.
Timeline (UTC)
• 07:11 UTC – AWS reports increased error rates and latencies across multiple services in us-east-1.
• 08:26 UTC – AWS confirms significant error rates for DynamoDB and other services.
• 09:01 UTC – AWS identifies the root cause as a DNS resolution issue affecting DynamoDB and dependent services.
• 09:22 UTC – AWS applies initial mitigations; early signs of recovery observed.
• 10:35 UTC – AWS confirms the DNS issue is fully mitigated; most services recovered.
• 11:08 UTC – Ongoing work to resolve EC2 launch errors and Lambda event processing delays.
Impact
• Temporary API latency and degraded performance in selected tokenization and proxy operations.
Status
Monitoring – Partial Recovery
Affected services